SUM node inventory fails

Symptom
  • Inventory does not respond on remote Windows nodes. The node logs display error message regarding the status of RegOpenEx.

  • SUM displays an inventory error on a VMware node.

Solution 1
Cause

Other processes, such as a backup or process that accesses the registry might be running on the remote Windows node.

Action
Shut down the remote process that is accessing the registry, or run SUM locally on the node to perform inventory and deploy updates.
Solution 2
Cause

The VMware service might not be running.

Action
  1. Make sure the VMware service is running. Log in to the VMware ESXi shell.
  2. Check the provider version, and then enter esxcli software vib list | grep smx.
  3. Verify if the provider service is running, and then enter /etc/init.d/sfcbd-watchdog status.
  4. Verify if the provider responds to queries, and then enter enum_instances SMX_SCInstallationService root/hpq.
  5. To restart the service, enter /etc/init.d/sfcbd-watchdog restart; /etc/init.d/sfcbd-watchdog status;.