SUM displays component failed validation error

Symptom

When SUM 8.0 is run on a Windows system to deploy SPP 2017.07.0, the Windows components install might fail with the error Signature validation failed on this component.

Cause

The issue is caused due to the missing root and CA certificates in the system. To resolve this issue, perform the following steps and retry the update.

Action
  1. Download the following two certificates:
    1. https://secure.globalsign.net/cacert/Root-R1.crt
    2. https://support.comodo.com/index.php?/Knowledgebase/Article/View/945/96/root-addtrust-external-ca-root
  2. Right-click a certificate and select Install Certificate.
    A Windows wizard appears.
  3. On the Welcome screen of the wizard, click Next.
  4. On the Certificate store page of the wizard, select Place all certificates in the following store.
  5. On the Certificate store page of the wizard, click the Browse button.
  6. In the Select Certificate Store dialog box, select Third Party Root Certification Authorities and click OK.
  7. On the Certificate store page of the wizard, click Next.
  8. On the Completing the Certificate Import Wizard page of the wizard, click Finish.
  9. Repeat steps 2-8 for the other certificate.