VMware node inventory displays an error

Symptom

HP SUM displays an inventory error on a VMware node.

Cause

The VMware service might not be running.

Action

Solution: Use the following steps to make sure the VMware service is running.

  1. Log in to the VMware ESXi shell.

  2. Check the provider version, type esxcli software vib list | grep smx.

  3. Verify that the provider service is running, type /etc/init.d/sfcbd-watchdog status.

  4. Verify that the provider responds to queries, type enum_instances SMX_SCInstallationService root/hpq.

  5. If you need to restart the service, type /etc/init.d/sfcbd-watchdog restart; /etc/init.d/sfcbd-watchdog status;.