SUM node inventory fails

Symptom:
  • Inventory fails on remote Windows nodes. The node logs display the error RegOpenKeyEx failed with error RegOpenKeyEx completed with error 997: Overlapped I/O operation is in progress.

  • SUM displays an inventory error on a VMware node.

  • SUM displays the error Inventory failed. The pciinfo module requires manual update on remote target for an HP-UX node.

Solution 1
Cause:

This might be an issue with other processes running on the remote Windows node, for example a backup or process that accesses the registry.

Action:
  1. Shut down the remote process that is accessing the registry, or run SUM locally on the node to perform inventory and deploy updates.
Solution 2
Cause:

The VMware service might not be running.

Action:
  1. Make sure the VMware service is running. Log in to the VMware ESXi Shell.
  2. Check the provider version, type esxcli software vib list | grep smx.
  3. Verify that the provider service is running, type /etc/init.d/sfcbd-watchdog status.
  4. Verify that the provider responds to queries, type enum_instances SMX_SCInstallationService root/hpq.
  5. To restart the service, type /etc/init.d/sfcbd-watchdog restart; /etc/init.d/sfcbd-watchdog status;.
Solution 3
Cause:

The pciinfo.depot file is in the wrong location.

Action:
  1. Close all tasks and back up important data on the node server.
  2. Log in to the node server with root privileges.
  3. Transfer the file pciinfo.depot, located in the SUM directory /ia64/ to the node server.
  4. Run swinstall -x autoreboot=true -s ‘pwd’ ./pciinfo.depot PCCIINFO.
  5. After the update finishes, you can rerun SUM on a remote host to continue with additional updates.