SUMノードのインベントリが失敗する

症状:
  • リモートのWindowsノードでインベントリの障害が発生する。ノードのログに、RegOpenKeyEx failed with error RegOpenKeyEx completed with error 997: Overlapped I/O operation is in progres:というエラーが表示されます。

  • SUMにVMwareノードのインベントリエラーが表示される。

  • SUMにエラー「Inventory failed.(インベントリが失敗しました。) The pciinfo module requires manual update on remote target(リモートターゲットでpciinfoモジュールの手動アップデートが必要です)」とHP-UXノードに表示されます。

解決方法 1
原因:

これは、バックアップやレジストリにアクセスするプロセスなど、リモートのWindowsノードで動作している別のプロセスでの問題である可能性があります。

アクション:
  1. レジストリにアクセスしているリモートプロセスをシャットダウンするか、ノードでローカルにSUMを実行し、インベントリを実行してアップデートを展開します。
解決方法 2
原因:

VMwareサービスが開始されていません。

アクション:
  1. VMwareサービスが実行されていることを確認します。VMware ESXiシェルにログインします。
  2. プロバイダーバージョンを確認し、esxcli software vib list | grep smxと入力します。
  3. プロバイダーサービスが実行されていることを確認し、/etc/init.d/sfcbd-watchdog statusと入力します。
  4. プロバイダーがクエリに応答することを確認し、enum_instances SMX_SCInstallationService root/hpqと入力します。
  5. サービスを再起動するには、/etc/init.d/sfcbd-watchdog restart; /etc/init.d/sfcbd-watchdog status;と入力します。
解決方法 3
原因:

pciinfo.depotファイルが誤った場所にあります。

アクション:
  1. すべてのタスクを閉じ、ノードの重要データをバックアップします。
  2. root権限でノードにログインします。
  3. SUMディレクトリ/ia64/にあるファイルpciinfo.depotをノードに転送します。
  4. swinstall -x autoreboot=true -s ‘pwd’ ./pciinfo.depot PCCIINFOを実行します。
  5. アップデートが終了したら、リモートホストでSUMを再実行して、追加のアップデートを続行できます。